CMake/cmake minimum required

En Galilibros, o Wikibooks en galego.
Saltar ata a navegación Saltar á procura
CMake
cmake minimum required Seguir con find_package


A orde cmake_minimum_required() permite establecer a versión mínima necesaria de CMake para o proxecto.

Sintaxe[editar]

cmake_minimum_required(VERSION principal[.secundaria[.parche[.axuste]]]
                         [FATAL_ERROR])

Se a versión de CMake empregada é inferior á necesaria deterase o procesamento do proxecto e informarase do erro. Cando se require unha versión superior á 2.4, a orde chama implicitamente á orde cmake_policy() do seguinte xeito:

cmake_policy(VERSION principal[.secundaria[.parche[.axuste]]])

Esta orde establece o nivel da versión da política de CMake á indicada. Se a versión é a 2.4 ou inferior, a chamada implícita será a seguinte:

cmake_policy(VERSION 2.4)

Esta orde activa funcionalidades de compatibilidade coa versión 2.4 de CMake e versións anteriores.

A opción FATAL_ERROR pode empregarse, pero ignorarase a partir da versión 2.6 de CMake. Debe empregarse para que as versións 2.4 e anteriores de CMake interrompan o procesamento do proxecto cun erro en vez de limitarse a imprimir unha advertencia.


CMake
cmake minimum required Seguir con find_package